Cloud portal of MyTilaa unavailable
Incident Report for Tilaa
Resolved
This incident has been resolved.
Posted Oct 18, 2023 - 20:00 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 18, 2023 - 19:40 CEST
Investigating
The cloud portal within My Tilaa is currently unavailable. We are currently investigating the cause.
Posted Oct 18, 2023 - 19:00 CEST
This incident affected: Services (MyTilaa).