Login to support portal
Incident Report for Tilaa
Resolved
The issue has been resolved, to be able to login.
You have to sign in to MyTilaa and press Sign in again on support.tilaa.com
Posted Aug 03, 2023 - 15:37 CEST
Identified
We have found the cause of this issue, we are applying a patch now.
Posted Aug 03, 2023 - 14:04 CEST
Investigating
We have noticed that customers are unable to login to support.tilaa.com
We are investigating how this is possible and will keep you up to date on here

If you want to reach us, please contact us by email at support@tilaa.com
Posted Aug 03, 2023 - 12:24 CEST
This incident affected: Services (Support Center).