Service Disruption: tilaa.com unreachable

Incident Report for Tilaa

Resolved

After a period of monitoring, we can confirm that the fix implemented by Cloudflare is stable. The website tilaa.com is fully accessible and performance has returned to normal levels.

This incident is now resolved. Thank you for your patience.

Final Status:
tilaa.com: Fully operational
my.tilaa.com (Dashboard): Fully operational.
nexaa.io: Fully operational.
portal.nexaa.io: Fully operational
Posted Dec 05, 2025 - 10:44 CET

Monitoring

Cloudflare has implemented a fix for the issue affecting tilaa.com. We have confirmed that the website is accessible again and traffic is flowing normally.

Our team will continue to monitor the situation closely to ensure stability remains consistent.
tilaa.com: Operational (Monitoring)
my.tilaa.com (Dashboard): Fully operational.
nexaa.io: Fully operational.
portal.nexaa.io: Fully operational
Posted Dec 05, 2025 - 10:14 CET

Identified

We are currently experiencing connectivity issues affecting our main website, tilaa.com. Visitors may be unable to load the landing page.

Current findings indicate this is related to an issue with our CDN provider, Cloudflare. Our engineering team is monitoring the situation and working on a resolution.

Impact Scope:

tilaa.com: Currently down / unreachable.
my.tilaa.com (Dashboard): Fully operational.
nexaa.io: Fully operational.
portal.nexaa.io: Fully operational

Next Update: We will provide further updates as soon as more information becomes available.
Posted Dec 05, 2025 - 10:03 CET