Investigating issues with AWS and Azure

Incident Report for Tilaa

Resolved

We are pleased to report that the network connectivity issues impacting our AWS and Azure services are now resolved.

Since our last update, we have observed a full restoration of service. This has been confirmed by several affected customers who report that connectivity is stable again.

It is important to note that no remedial actions were taken on our infrastructure to resolve this. The spontaneous recovery indicates the issue was addressed externally, likely within Microsoft's network.

We thank you for your patience and collaboration. This incident is now closed.
Posted Sep 02, 2025 - 11:38 CEST

Monitoring

Following an extensive investigation, we have isolated the cause of the recent network issues. The problem is now confirmed to be limited to connections with services hosted on Microsoft Azure.

Our analysis shows that all traffic is leaving our network correctly, but that packet loss is occurring within the Azure network.

We have provided affected customers with the necessary technical details to escalate this issue with Microsoft Azure Support. As the resolution lies within Microsoft's domain, this is the most effective path to a solution.

We will continue to monitor the situation closely and will post a new update as soon as more information becomes available.
Posted Aug 20, 2025 - 09:39 CEST

Investigating

We are currently investigating issues between Tilaa services and external cloud services (AWS and Azure), with reported TCP delays and/or timeouts towards these external cloud services

Our team is working hard to identify the root cause and restore service as quickly as possible. We apologize for any inconvenience and will keep you updated.
Posted Aug 18, 2025 - 11:25 CEST
This incident affected: Data Center (Amsterdam, Haarlem) and Services (Networking).