All maintenance work is now complete. Network traffic has been successfully switched and balanced across our providers. The previous congestion and packet loss issues are resolved, and the network is stable. We will be monitoring the network, and if the issue returns, we will take action on the matter. If you still see issues regarding this maintenance, then give us a call or email us at support@tilaa.com
Posted Nov 05, 2025 - 21:48 CET
Update
Following scheduled maintenance to switch network upstreams, we are observing packet loss and congestion. This is due to traffic being temporarily rerouted through a single provider. We are finalizing the new connections, and services are beginning to stabilize.
Posted Nov 05, 2025 - 21:30 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 05, 2025 - 21:00 CET
Scheduled
We will be performing network-related maintenance on our infrastructure. This maintenance is not expected to cause any system downtime or disruption to regular activities. We have taken precautions to minimize any potential impact, and our team will be closely monitoring the network throughout the maintenance window. If you encounter any issues, don't hesitate to get in touch with support at support@tilaa.com
Posted Oct 27, 2025 - 08:26 CET
This scheduled maintenance affected: Data Center (Haarlem) and Services (Networking).