As of 10:43 AM CEST, we have deployed a fix for the issue affecting our 2FA system. We have verified that login prompts are now working as expected.
We are moving this issue to a "Monitoring" status. Our team has added enhanced monitoring dashboards and will continue to actively watch the service to ensure its stability and performance. We will post a final update once we are confident the issue is fully resolved.
Posted Jul 21, 2025 - 10:44 CEST
Investigating
We have identified an issue affecting our Two-Factor Authentication (2FA) system. While you can still log into MyTilaa, the system is not prompting for the second factor verification code.
This results in a temporary degradation of account security, as logins are being authenticated with only a password. We understand the critical importance of 2FA, and our engineering team is treating this as a high-priority incident. We apologize for this issue and will post another update as soon as we have more information.
Posted Jul 21, 2025 - 10:12 CEST
This incident affected: Services (MyTilaa, Nexaa).