PayPal issues
Incident Report for Tilaa
Resolved
The issue has been resolved by PayPal.
Posted Apr 17, 2023 - 15:38 CEST
Monitoring
We have been in contact with PayPal. They have confirmed there is a problem. Payments should go through once they have solved their issue. As an alternative, you can choose one of our other payment methods. We apologize for the inconvenience.
Posted Apr 17, 2023 - 12:17 CEST
Identified
We are experiencing issues with PayPal, as payments are not coming through. We are addressing this issue, and will update this page as soon as we have found the root cause.
Posted Apr 17, 2023 - 12:16 CEST
This incident affected: Services (MyTilaa).