Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2025 - 21:00 CEST
Scheduled
We will be conducting scheduled maintenance to upgrade one of our edge routers in Amsterdam.
Impact:
While our redundant network design will minimize impact, some customers may experience brief periods of increased latency or minor packet loss to and from the Internet as network routes reconverge.
Specifically, there is a possibility that IPv6 connectivity will be temporarily interrupted during the procedure. No major downtime is anticipated for other services.
Reason:
This upgrade is essential to enhance and further augment the performance, stability, and capacity of our network infrastructure.
We appreciate your understanding as we work to improve our services.
Posted Oct 02, 2025 - 10:17 CEST
This scheduled maintenance affected: Data Center (Amsterdam) and Services (Networking).